More web-store problems!

All topics including role playing games, board games, etc., etc.
Post Reply
Kurgan
Ungern
Posts: 87
Joined: Thu Aug 30, 2007 7:00 am

More web-store problems!

Post by Kurgan »

Ok, earlier today (technically yesterday, now) something odd happened while I was nosing around on the web-store. Items suddenly began disappearing from my shopping cart, and other things suddenly began appearing. Happened several times in a row, every time I tried to click a page link, with apparently random stuff jumping in and out of the cart. Then some image links stopped working, then came back.

Anyhow, I told Steve about it to play it safe. Might have just been my system going haywire, but you never know.

Tonight, however, I got an email from "Steve" (a system message, I'm certain) telling me about an order I'd just placed. I hadn't. I looked at the address, and it was to someone else, in another state. Went online to see if it was real, and sure enough, the order is in my account. The weird thing is, though, that I wasn't charged for it. It says it was paid for via Paypal Express (I use Paypal, but don't know what "express" is). I'm wondering if it's not a hacker, but a glitch of some sort merging accounts or something? I dunno.

Anywho, I've gotta call Steve tomorrow, and will report this problem then, but figured I'd post this now in case someone's still awake who can look into it.

User avatar
Troll Lord
Greater Lore Drake
Posts: 3232
Joined: Thu Mar 30, 2006 8:00 am

Re: More web-store problems!

Post by Troll Lord »

This is rather interesting. There was no sign of the site being hacked. And of course we don't store any card numbers or any financial information on the site.

Paypal express is the company that processes your credit card when you use credit cards for purchasing and not paypal.

Give me a shout, but there seems to be no anomalies with other purchases.

Steve
_____________________________
He Who Sits on the Elephants Back
The Troll Lord
Steve Chenault, President & CEO of Chenault & Gray Publishing, Troll Lord Games

serleran
Mogrl
Posts: 13866
Joined: Mon Oct 13, 2008 7:00 am

Re: More web-store problems!

Post by serleran »

Kurgan -- you should check your system for spyware and Trojans. Trolls only deal with Sparta.

Kurgan
Ungern
Posts: 87
Joined: Thu Aug 30, 2007 7:00 am

Re: More web-store problems!

Post by Kurgan »

Ah, lad, ye never hafta worry yerself about nasty stuff on muy machine. :)

I'm an old hand at this stuff. Haven't had a virus, trojan, malware, worm, or anything else nasty in decades. Literally. Interestingly enough, although I do run antivirus software, firewall, and malware protection, the most effective thing I ever did was to simply not use anything of Microsoft's other than the OS itself. IE is about as secure as a chastity belt made out of tissue paper, and just begging for a Trojan (hah! I slay me), and Firefox... well, don't get me started on that craptacular and sadly-popular piece of "software." The only browser that's actually worth its salt is Opera, which also happens to be pretty much invulnerable to exploits and viruses. Been using it for many years, now.

I'm fairly certain now that the weirdness from earlier in the day was due to my system being overloaded and short on memory. My PC died quite some time ago, as did my good laptop, so for almost a year now I've been using an older, used laptop I picked up on eBay, and I've maxed it out at 2 GB memory, and the best the CPU will handle is Vista (can't run Win7 --not enough resources). I must have simply had too many tabs open in Opera.

But the thing that happened later, with me getting someone else's order in my account, couldn't have been a localized thing, as far as I understand things (admittedly that's an area where I'm lacking significant skills, but from what I knew it shouldn't be possible). Some sort of momentary server/DB hiccup is the most reasonable explanation.

User avatar
mgtremaine
Ulthal
Posts: 475
Joined: Tue Dec 16, 2008 8:00 am
Location: San Diego, Ca
Contact:

Re: More web-store problems!

Post by mgtremaine »

It would be pretty strange for the DB to return the wrong data, I would be more prone to believe that somehow there was a cookie clash or something browser side that had to do with php session info.

Did you happen to get a cut and paste of the shipping info? They could from that at least see who's account it was and if they got their order sorted out correctly.

-Mike

Kurgan
Ungern
Posts: 87
Joined: Thu Aug 30, 2007 7:00 am

Re: More web-store problems!

Post by Kurgan »

Didn't need a cut-n-paste, the order is still listed on my account. Steve already emailed the person.

The order, although listed on my account, had the person's name and address under both "order" and "ship to," and apparently got billed properly to their credit card. I wasn't charged for it or anything.

The odd thing, and I completely forgot to mention this to Steve, is that I wasn't online when it happened. I'd taken my meds for the evening and they knocked me right out for several hours. I typically check email when I wake up (something to keep me occupied while the dendrites start firing-up), and spotted the system message telling me about the order, and the time stamp shows it occurred while I was still zonked. That leads me back away from a cookie problem and back to some server glitch, unless someone else's cookie could be corrupted and send the wrong account info? Beats me.

Post Reply